Fecking Fedora

I made the mistake of trying the Yum Upgrade method of moving my rock-solid F13 install to F14 before they end-of-life’d it. Well that resulted in a machine that would constantly reboot at the “Loading operating system….” bit just before Grub. I couldn’t fix it no matter how many times I tried variations of “grub-install /dev/sda”.

So I decided I might as well bite the bullet and do a fresh install of Fedora 15. The first problem there was that my computer becomes very unreliable when I plug in the DVD drive (I really have to buy a new PSU) so I created a bootable USB installation using the UNetBootIn instructions. Well that took literally hours to write 3Gb to my flash drive on Ubuntu for some reason and then wouldn’t boot anyway, the fix was to type “/isolinux/vmlinuz initrd=/isolinux/initrd.img” at the boot: prompt.

So I merrily went and selected a smallish installation, not every package a I usually would do. Apparently this came to over 2000 packages! 4 hours later its still installing, then I notice the switch is blinking like crazy, guess what – despite unticking the “Use Fedora Updates repository” option, it seems to be downloading 2000+ RPM’s from the internet!

Anyway, eventually I’m booted and into Gnome3 – well what a screwup that is – I can’t even find where to configure the screensaver! The only thing I like about it is I don’t have to spend a day configuring compiz-fusion plugins as most of what I use is built-in and preconfigured now (like drag’n’drop windows between workspaces). Gnome-Shell I hate, what is it with having to search through a list of all your applications rather than just selecting from a menu?!

I found this site which at least tells you how to move the stupid clock and get the shutdown menu back again.

The SysV-init replacement “systemd” doesn’t integrate with any of the GUI tools for configuring services and doesn’t work with akmods so every kernel update is going to be fun with NVidia/VirualBox. I can see that becoming the next PulseAudio heathen.

For some reason NFS is all screwed up with Nautilus and won’t let a regular user unmount (although it will mount!) despite what /etc/fstab says. So I went back to autofs, which at least these days seems to cope with the remote server being offline. Then I noticed that USB drives won’t mount – turns out I can’t use /media for NFS mounts anymore, so have to create a specific /nfs directory now:

/etc/auto.master:

/nfs /etc/auto.nfs --timeout=3600 --ghost

/etc/auto.nfs:

data0 -fstype=nfs4,hard,intr,timeo=10,rw,rsize=32768,wsize=32768,noatime server:/data0
data1 -fstype=nfs4,hard,intr,timeo=10,rw,rsize=32768,wsize=32768,noatime server:/data1

So I’m pretty much back at a working system now, although I’m getting the odd hard-lockup like I was with F14 (despite removing USB/DVD devices) so I think I need a new PSU. Odd that F13 was fine.

Skype works, Firefox4 by default, Nessus’ F13 RPM works, VirtualBox has a new F15 RPM, I can rsync all my servers etc. I rebuilt my RPM’s for JtR, gSTM, gIP and knockd and I built VirtualBox4 and CyanogenMod7 using Sun JDK.

I noticed that even if you run “ssh-add” you still get a popup dialog box from gnome-seahorse-whatever asking for the passphrase. Apparently ssh-add is deprecated, and ssh-agent is fired up by the dialog now, so just enter the passphrase in there and it will cache it in the agent.

Nothing but Totem will play .FLV files for some reason – I think RPMFusion broke their MPlayer build or something.

Whenever I fire up QGit now I get some annoying warning:

An error occurred while executing command: git repo-config --get i18n.commitencoding
Git says: WARNING: git repo-config is deprecated in favor of git config.

One thing I noticed was that when restoring, BackInTime (root) sets all the directory modification times to now, although files get their original datestamp. Bit of a shame that, as it means sorting a directory listing my date is pretty ineffectual.